Go Back   The Construct Forums > Gaming > The Construct > Construction FAQ
User Name
Password


 
 
Thread Tools Search this Thread Display Modes
1 - 10-19-2006, 03:19 PM
Krash
Neptune Sleeps
 
Krash's Avatar
 
Join Date: Nov 2006
Posts: 1,356
Offline
Default [Servers] General Troubleshooting

Still compiling questions. Submit anything you need help with in the "Construction Help" forum.



This kinda stinks so far, but that's too bad.

Quote:
Originally Posted by JackTL
* Install latest T2 patch......................................... check?

* Install latest Construction..................................... check?

* Delete ALL *.dso files in both base and Construction folders,
including subfolders, EXCEPT in the "do_not_delete" folder .....

* Verify that all *.dso files are deleted.........................

* Verify that your Construction launch shortcut is correct........

* Launch Construction before launching a base game again..........

* Verify that you have no other add-on scripts causing problems...
After you have checked through the FAQ, if your problems are not solved post a thread in the "Construction Help" section.


-------

Problem: When I host a Construction server, none of the packs are selectable and I spawn with the base weapons. Purebuild isn't available.

Why: This is caused by .dso overlay. The compiled scripts from whatever you played before you started the server are still in the folder and the Construction scripts cannot be loaded.

Solution: Run the DSO remover included with the mod.
This is available in "Dynamix\Tribes2\GameData\Construction". Running your server immediately after this has finished should result in the game working properly.

If your server still does not start up with the mod, use "prepbuild();" in your server console. This will hang for a few minutes, after which you should close and restart your server.

If it still does not work, do a search for the files (Ctrl+f or F3 will open the search panel on windows) in your Base and Construction folders. Using .dso as the search term should bring up a number of files, all of which should be deleted, except for those in the do_not_delete directory - which are Read Only and will prompt you for permission (answer "No.").

-------

Problem: I started my server fine, but when I deploy something, it stretches out to the ends of the earth!

Why:



  1. Your Dfunctions file has been deleted, or has not loaded. This is a required component of the mod, hence why it is in the do_not_delete directory.
  2. You deleted (or overwrote) the loadscreen.cs.dso in the do_not_delete directory. Bad idea.
Solution:

1.
If you can verify that the file is there (along with loadscreen.cs.dso), it is likely not being loaded. This could be because of a previous dso version of server.cs (in your scripts folder) is being loaded (delete DSOs again, see above), or your server.cs itself may have been modified and doesn't include the proper exec lines.

If you have accidentally deleted this file, you may download it below (This works for sub-mods of Construction as well)
http://www.the-construct.net/Dfunctions.cs
http://www.the-construct.net/Dfunctions.cs.dso (Precompiled)


http://www.the-construct.net/loadscreen.cs.dso (Required to be in do_not_delete)



Put the file in your "Construction\scripts\do_not_delete\" folder.


-------

Problem: When I delete one piece, all the rest explode!

Why: Cascade mode is enabled. This causes pieces deployed on the one you delete to all deconstruct.

Solution:
  1. As an admin, press Esc to access the lobby menu.
  2. Locate the menu in the upper right corner (above the chat) with the admin functions in it.
  3. Scroll down this list until you find































    [pure] Disable Cascade Mode
  4. Double-click it and you should recieve a message in chat notifying that it has been disabled.
-------

Q: What ports does Tribes 2 use?

A:

TCP Ports: 15101,15104,15024,15206,15800
UDP ports: 27999,28000, and whatever ports you plan on hosting on.

You can generally open a range if you plan on hosting on multiple ports.

-------

Problem:
Why:
Solution:

-------

Problem:
Why:
Solution:

-------

Problem:
Why:
Solution:

-------

Problem:
Why:
Solution:
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are Off
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Noob ergo46 General Discussion 12 02-16-2010 03:52 PM
TWM and TWM 2 Rank Lists Phantom139 The Construct 2 07-19-2009 12:15 PM
General Discussion Purple Duck General Discussion 18 05-26-2009 01:15 PM
General Chit Chat Deflun General Discussion 85 02-15-2009 03:52 AM
General Music Thread Glavien General Discussion 6 12-21-2008 11:04 AM



All times are GMT -7. The time now is 07:41 AM.
Powered by: vBulletin Version 3.0.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.