Structrual Infinity

13»

Comments

  • HumansHumans yes i built that
    *sigh* Nobody has SI so they just get pissed at me for trying to load anything.
  • DEATHBORNDEATHBORN Reborn from death...!
    im having some very strange issues, i have all the up to date stuff, but cant see beyond 1500 pieces is this... usual? or is it just me... :(
  • ThythThyth AKA Electricutioner
    Just you.

    Oh and, I'll release a new executable/DLL pair for SI servers. Should bring server SI statuses from yellow (no slack space) back to green. I've been testing on Inquisition and it seems to work. It just needs a bit of polish prior to release.
  • DEATHBORNDEATHBORN Reborn from death...!
    Thyth wrote:
    Just you.

    Oh and, I'll release a new executable/DLL pair for SI servers. Should bring server SI statuses from yellow (no slack space) back to green. I've been testing on Inquisition and it seems to work. It just needs a bit of polish prior to release.

    awesome, i remember back then i had no trouble when it was like that :D
  • JetBuJetBu TWM Staff
    Is there any possible way to make SI compatible with TWM 2?
  • Phantom139Phantom139 PGD Founder
    I think you're referring to the general console errors, correct?

    Because SI seems to work fine on Soulice's Server, you could ask him.
  • Fast_FireFast_Fire Killercowzz
    Waffles solve everything.
  • SouliceSoulice TEF Engineer
    Phantom139 wrote:
    I think you're referring to the general console errors, correct?

    Because SI seems to work fine on Soulice's Server, you could ask him.
    Someone wanted to ask me something? I don't know why mine works correctly and yours doesn't, gimme one second to sort that out...
  • SouliceSoulice TEF Engineer
    It executes in a vl2 or cs file, open it up, copy it, then PM Thyth about it, see if there are errors...
  • ThythThyth AKA Electricutioner
    Client 0.9 and Server 0.7 have been pushed to the auto-update system. The primary addition are notifications for damage and animations on SI pieces, along with a new health HUD on the client side.

    The improvements significantly lessen the user experience differences between SI generated objects and server generated objects. For example, generators are now indistinguishable between the two sources.
  • DEATHBORNDEATHBORN Reborn from death...!
    Thyth wrote:
    Client 0.9 and Server 0.7 have been pushed to the auto-update system. The primary addition are notifications for damage and animations on SI pieces, along with a new health HUD on the client side.

    The improvements significantly lessen the user experience differences between SI generated objects and server generated objects. For example, generators are now indistinguishable between the two sources.

    if we get issues, is it recommended we manually download SI? and if so, where may we get it, or is the latest version link on your first post updated?
  • Signal360Signal360 KeyboardCat
    The SI Installation package consists of only an auto-updater which downloads the SI script from the server when the game starts, downloading the installer again will not fix anything unless the problem is with the auto-updater itself.
  • ShrimpFromHellShrimpFromHell Me is teh Shrimpeh!
    When I host a server and I join it, it says "Slack space creation failure".
  • ShrimpFromHellShrimpFromHell Me is teh Shrimpeh!
    Never mind, I somehow got it to work.
  • darkavenger_35darkavenger_35 =TKM={{cha0s}}
    I keep trying to download krash's version but it's not working for me, i just get a bunch of symbols
  • KrashKrash Neptune Sleeps
    It's an installer executable that extracts one script file to Construction/scripts/autoexec/ (and optionally installs Flatland). Right click and Save As... to a local folder or your desktop, and run it.

    Again, the file is installed to you Construction directory, so the game must be started running Construction mod - either by using the shortcuts provided, or by using your own, pointing to:
    Tribes2.exe -online -mod Construction
  • darkavenger_35darkavenger_35 =TKM={{cha0s}}
    It's still not working
  • KrashKrash Neptune Sleeps
    Your description of the problem is very vague. Did you run the installer? Did you install it to the directory where you installed the game? Did you opt to install the start menu shortcuts? Did you run the game from the installed shortcuts ("Construction Online (SI)" from under Start > Dynamix > Tribes 2)? Did you wait a few seconds before joining a game?



    I did a run through of the install process just now, and you should've been able to get it working fine by installing and running the shortcut, albeit with an old version of the script which most people who installed it recently will have been using.
    I did notice that the version of the script bundled with the installer had a bug that failed to close the file when updating (and created a syntax error so it wouldn't compile when the game loads next) - but I put in a bit of a bypass that should resolve that after everyone else runs the update sequence a couple more times. I will rewrite the installer itself sometime soon.
  • SI Krash'd. :lol:
  • KrashKrash Neptune Sleeps
    There is a small experimental update to the client from the installer that should significantly decrease load times (just on the BC server at the moment). The current version still does cause you to hang for a moment, but the transfer time will be a fraction of what it was.

    Also, there may be a couple more updates soon-ish to work out some remaining kinks.
  • HumansHumans yes i built that
    :D :D
  • KrashKrash Neptune Sleeps
    Also, if the new RPC channel fails, it will smoothly fall back to the standard system, so it might not be obvious if/when it breaks. To see if it's working at all though, when you see the green SI popup, you can open your console(~) and should see a message saying, "SI RPC channel successfully connected".
    That or load something big.
Sign In or Register to comment.