Bad Metallic Install?

It's good to see that this project is still up and running, it's been one of my favorites.

I used to run construction several years ago with a much earlier version. Now, I've gotten back into Tribes2 and would like to run the Const mod on my computer for local play with bots. So I downloaded Metallic 1.4 etc. and I can run a local server with it. Problem is, first of all, I don't know how to use anything except for the obvious packs. I can't get things to be powered (ie. forcefields etc), and everytime I place a support beam, it's not a support beam, it's an infinitely long walkway. And the placeable "floor" is actually infinitely large in area and roughly 30m thick!! It seems as though something is screwed up with my install.

Now, I'm not running the latest Tribes2 version available (last time I updated to that, the entire game ran at 100x normal speed, bots zipped around like lightning and it was unplayable). Running under Windows XP...


help?

Comments

  • TThyth AKA Electricutioner
    The strange deployable sizes means that you are probably missing dfunctions. It is a .cs.dso file inside the scripts/do_not_delete/ directory.

    Which version of T2 are you running?
  • I have both dfunctions.cs and dfunctions.cs.dso (and loadscreen.cs.dso) in the do_not_delete folder


    I'm running Tribes2 version 24834


    Perhaps I just need to update Tribes2 and hope that it doesn't go into speedy mode again ; )



    EDIT:
    I've attached 2 screenshots of what I'm talking about. The first is a deployed light support beam, which when used looks like an infinitely long walkway. The second is a shot of the light walkway, which looks like a very large ceiling! (It's invisible when you look at it from the top, so when you deploy it on the ground, like the top of a mountain, you have to go down into a valley before you can see the bottom which is textured. Also, once you go down to the valley, you can't get back out since it's a solid object.)
    • light support beam.jpg
    • light walkway.jpg
  • KrashKrash Neptune Sleeps
    To get around the usual dso problem with the stretching beams you can open up dfunctions.cs and putting '$MissionDisplay = true;' at the top (or search through the file and remove the few lines below '// for loadscreen.cs'), and remove dfunctions.cs.dso.

    Did you place a power source (generator / solar panel) for the forcefields?


    Well, the mod should be run on an up-to-date version. Might you be running on a dual-core processor, and if so, have you tried setting your processor affinity?
  • I am using a dual-core processor and have not manually set such a preference, nor heard of such an option.


    As for the force field, I will enter a game, get a "generator pack" or solar pack and place it. Then I will resupply with a force field pack and try to place it and get the no power source error - pack not placed message.

    I'll look into the dfunctions file
  • KrashKrash Neptune Sleeps
    You can usually do it in the Task manager, right-clicking the process and using the "Set Affinity" option.
    You could also make a new text file with the below, rename it to a .bat, and use it as your shortcut.
    CD C:\Path\to\Tribes2\Gamedata\
     start /affinity 1 Tribes2.exe -online -mod Construction
    
  • It works it works! I updated Tribes2, set it's affinity to only a single CPU, and added the line in Dfunctions.cs and now they work properly. Now everything runs at proper speed, and with proper entities.


    Thanks! (oh the funness of the const mod ;) )
  • wierd i have a 3ghz duel core AMD processer and i dont get speedy bots

    i did have this weird issue the other day tho i was... lagging tried everything turning down settings to min and all and in the end enabling v sync fixed it.. witch is odd because now i disabled it because i was lagging with it enabled and now i don't drop below 190fps with all the settings on max

    wth was with that lol (hope you understand wtf i just said)
  • CornucopiaCornucopia That One Guy
    Lol, that happened to me once, took me forever to find out how to fix it. All I did was restart my computer. As with the fps, I get around 235-242, It drops by 8 when a numerous amount of forcefields are placed in view of my screen.
  • KrashKrash Neptune Sleeps
    By enable you must mean disable... Vsync limits the frame rate to match the requests of the hardware, so if your refresh rate is 60 Hertz, the max FPS will be 60. It's usually handy if you get artifacts when playing with an LCD, but with T2 you'll get a serious performance drop.
  • TThyth AKA Electricutioner
    V-sync in any situation other than extremely over-powered video hardware can and will result in frame-rate drops to half, third, or fourth of V-sync refresh rate. It is the way the frame buffer is filled...

    The main reason Construction kills frame rates is the complete lack of Z-buffer or occlusion querying for objects that are not part of an interior instance or the terrain.
Sign In or Register to comment.