IS question/help

Hi guys.
I wanted to ask if some one els has problems with SI. The thing is when ever i construct something i build up to about 2k object and afther that it just stops showing the objects or i place 1 object and an other dissapears. If none of you have the same problem does one of you prehaps have a solution ? I would try to fix it my self but i realy dont know what i would be doing and probably do more harm then good.
Thanks in advance and for taking the time to read this.
Greetings Yuzuyu


  • KrashKrash Neptune Sleeps
    Structural infinity will not stop functioning at ~2000 objects. However, if objects stop appearing around 1000 pieces, then the SI server script is not active, as 1024 is the default visual limit (including the terrain, sky, players, etc).
    Make sure that StructInf/server.cs is being executed on startup and it should clear up this problem.

    Keep in mind, the SI server script cannot be run on a listen server (or more accurately, if it is, players joining will be able to use SI, but the host will not), so make sure the server you're trying to use SI on is run in dedicated.

    Also, the setGhostable SI server support function is not currently supported with the current TN patch (you should see a "slack space creation failure" message to inform you of this), so when you pass the regular visual limit, new/respawning players will be unable to spawn unless a piece is removed... among other things. SI will still work, just make sure you don't need vehicles or kill yourself. There is an older LAN-patched executable you can use if you are adventurous, but you will not be able to use accounts with it.
  • Do i need an other patch for SI lan ? i didnt know that. That would clear up a lot though becous i only host dedicated lan servers. I dont know if it helps but i downloaded SI from here :

    If thats not the right one for Lan servers then could you please tell me what i sould download and install for a lan server. I searched on google for :Structural Infinity lan.
    But it didnt realy come up with anny thing. When i do start up a dedicated lan server
    the SI does update. The server says at the end :

    Deleting file 'base/structinf/client.cs'.
    Updating Structrual Infinity Server...
    Deleting file 'Construction/Structinf/server.cs

    I hope this info helps.
    Thanks for the answer you have already given me Krash
    Greetings Yuzuyu
  • KrashKrash Neptune Sleeps
    No. You do not need another patch. As I stated, the support function is for slack space, and is not required by SI.
    If you're adventurous there is an old server EXE that can be used to enable slack space on servers without the TribesNext patch, but again, it is not required.

    Using the auto-update version of the SI script, it should display something along the lines of "File update complete." when it finishes the update and executes the file. If it does, you should be fine - and it should pop up messages when you get ingame.
    If the server you're running doesn't have an internet connection, you will need to remove the auto-updater and make sure the server script is placed and executed properly by hand.
  • It doesnt say File update complete or anny thing like it. it just says
    Updating Structrual Infinity Client...
    Deleting file 'base/structinf/client.cs'.
    Updating Structrual Infinity Server...
    Deleting file 'Construction/Structinf/server.cs
    And after that it just starts the game :s.
    If i want to load it by hand where do i need to place the server script and how do i load it ?
    Thanks for your time Krash
    Greetings Yuzuyu
  • KrashKrash Neptune Sleeps
    From the sounds of it, I would guess that the auto-update script isn't reading the #EOF marker to trigger closing and executing the file. Basically, it sits waiting for more lines to be written and never completes.

    To disable the auto-update, first thing you'll want to do is close the server and delete 'structinf_a01.vl2', followed by removing DSOs - there should be a DSO remover batch file in your construction folder.
    Since it is downloading a file to 'Construction/StructInf/server.cs', you can open that up and verify that there is nothing odd in the file (such as HTTP headers; the first line should read "// Structural Infinity Server - Core") and that the last line is a bracket, not "#EOF". If it is beyond saving or doesn't exist, you can download a fresh copy here, but again you will have to open it up and remove the last line from the file.

    Make a backup of the file so you don't lose the changes you made if you accidentally missed a piece of the auto-updater, and start up the server. It should not give the update messages, but once it completes startup you can enter the following in the server console:
    If you haven't made any mistakes in the file, it should load and SI should be working on your server.
  • Thanks alot i got the SI server to work now :).
    How ever i do have an other question now witch realy confuses me after i started the server i started up tribes and joined to see if it worked. but now i get red text saying that the server is working on SI and that i dont have SI so im not able to see over 1024 objects. But thats the confusing part becous i start up tribes with the same tribes i hosted the game from so SI sould be instald right ? or am i missing something again :s. Do you prehaps have the answer to this as well ?
    In anny case thanks alot for helping me set up the server i realy aprishiate all the help your giving me.
    Greetings Yuzuyu

    ps. I dont know if it has anny thing to do with it but when i exec the server.cs it says:
    Loading compiled script StructInf/server.cs
    StructInf/server.cs (247): Unable to find function reflect_isFuncion

    I thought it had something to do with the fact that im not hosting online or that it only effected online hosting but sinds im not intiraly sure i though ill just say i have that error.
  • KrashKrash Neptune Sleeps
    The red error does actually say what the problem is: You aren't running the SI client.
    Since you aren't running the package auto-updater, you will either need to add it on your own or use the quick-install client.

    The "Unable to find function" error is just a RC3 server check. The only difference between "online" and "offline" hosting is that you'll be unable to use accounts offline, so your pieces won't really belong to anybody.
  • Then can you please give me the SI client sinds the quick-install client isnt working for me for some reason. I have reinstald tribes and SI manny times already hoping that would fix it but i still get the same red error code. And i dont thing i would get the right client if it did work becous the server.cs was in it but it whas a completely different code then the one you gave me.
    Greetings Yuzuyu
  • KrashKrash Neptune Sleeps
    You need to run the game using the shortcuts provided by the installer (or create your own with "-mod Construction" in the target). The client installs in your Construction mod folder, and will not load if you run the base shortcuts.
  • Fast_FireFast_Fire Killercowzz
    Isn't there some kind of manual that covers most of what was asked/suggested here?
  • Thanks alot for all the help i got it to work now :D:D.
    I dont know it there is a manual i never found it if there is one.
    Greetings Yuzuyu
Sign In or Register to comment.