Problems Hosting Con Server

Ok, so I too like Master-Chief am having problems with hosting a dedicated construction server. As I click host in the host tab, it says if I am sure that I would like to close tribes 2 in order to ost the server, correct? I click yes and it closes tribes 2 for me, and I wait say 10 seconds. An undefined error comes up and it says
unidentified expression:XXXXXX
????????:XXXXXXXXX
I cannot recall what the bottom part said and the X's simply represent numbers. If anyone knows what is going on I'd be morethan happy to get the exact numbers and everything. Any help?

Comments

  • KrashKrash Neptune Sleeps
    If the error you're getting is an "Unhandled Exception", first you should try removing all your DSOs again and try to run the dedicated server from the shortcut provided in the folder.
    Also, next time if when you run it the server console is visable, try to see what it says as the last few lines.

    If it still doesn't run, it's likely you're running third-party scripts in confliction with the mod. Make sure to remove any PJ scripts, for example -- and delete the DSOs again after removing the scripts. It would be a good idea to move any scripts you have and attempt to run the server.
    What you could do is move any scripts you've downloaded to an outside directory and add them back in one at a time to make sure they don't conflict with the mod.
  • ffusheelantreeno TopherChee--OverLord
    i ran a quantium and a construction dso remover and it still didnt work...ill remove any pj scripts i can find.

    [edit]
    ok i ran a metallic con dso remover and the quantium still no progress here is the exact reply i got to attempting to open the dedicated con server

    unhandled expression:c0000005
    at adress:004c6c99
  • KrashKrash Neptune Sleeps
    All the DSO removers are essentially the same, you only need one to remove the files (they are generated each time you run the game of course). The unhandled exception itself was not caused by a dso. I take it the server dos box itself didn't pop up at all?

    When I mentioned PJ's scripts, it is only because they're a very common problem to construction servers. There are countless other custom scripts that may conflict, so you should be checking everything you've got.
  • ffusheelantreeno TopherChee--OverLord
    well i deleted all the dso files...in the classic folder should i delete the autonload.dso and the console_end.dso? I dont have any PJ scripts so.....its all ok....the window never pops up like you said. Got any idea whats wrong?
  • I fixed mine by renaming my construction folder to construction_q (for QX,) then installing the Metallix beta. Seems to run fine on my primary PC. It used to crash during server initialization.
    ...however... I installed on my secondary PC to teach my daughter how to build. Not sure how good I'll do considering I'm still pretty green. I'm getting the unhandled exception on her PC but it pops up a second or so after I run from the short cut. I don't even get to the splash screen!
    Flustered... so's my lil' girl... :sigh:
  • KrashKrash Neptune Sleeps
    Sometimes this happens when the game doesn't quite agree with the computer's media components.
    Try opening up GameData\Construction\Prefs\Clientprefs.cs and putting:
    $pref::SkipIntro = "1";
  • Great! :cool:
    I'll give it a try and let you know. Thanks a megaton!
Sign In or Register to comment.