Help with hosting a server please

andr3wrulzandr3wrulz Shadow Assassin Lord
Hello and thanks in advance,

Ive wanted to host my own server, for mainly me and my brother to mess around on, for a while now and I was wondering if I could get some help with my problems.

Every time I try to host a dedicated server I get this

and when I host an undedicated I get this

These are my specs

And yes I forwarded my ports to the best of my knowledge

I have Avast running but if im going to host a dedicated server I do not want to leave my computer unprotected so thats kinda out of the question unless you have another solution or a way to bypass it.

Either way thanks for your time and any information even if its directly related to my problem would be awesome!


  • Numbuh 178Numbuh 178 Senior Member
    I doubt Avast is blocking it, the error in the ded console means you did not forward the ports correctly, and that UE may be caused if you have SI installed.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    I have SI and to the best of my knowledge I forwarded my ports correctly (please check screenshot to see if im wrong). Would uninstall of SI work, although I do want to be able to use it....
    btw thanks for the quick response
  • DEATHBORNDEATHBORN Reborn from death...!
    numbnuts is right, hes been hosting ded with it on but i think it canc ause problems, it seems to be mod specific however
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    Ive tried metallic, moocon, accm and plain old construction mod all the same results
  • DEATHBORNDEATHBORN Reborn from death...!
    have tried using custom shortcuts? wheres your tribes2.exe located

    there IS one possible way of getting around the SI thing by using the provided shortcut, currently t2 is only patched for SI CLIENTS not servers (i think...) so you have to manually activate it with that shortcut, lemme know what happens next, screens if need be ^^
  • Numbuh 178Numbuh 178 Senior Member
    I'm telling you, the "Your server could not be contacted" means you did not forward the ports correctly most likely.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    :( that took forever but I shall try again

    Could you tell me if you see something wrong with the screenshot?
  • Numbuh 178Numbuh 178 Senior Member
    I've tried to port forward for my own server and failed, you'll have to ask someone else about that, sorry.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    aw okay so does anyone else know anything about port forwarding???
  • Fast_FireFast_Fire Killercowzz

    It didn't help me with hosting of any sort, but maybe it'll work for you instead.
  • Numbuh 178Numbuh 178 Senior Member
    I tried that website also, didn't help.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    Thats the one I used but apparently to no avail
  • Spin1441Spin1441 Skanky's Proprietor
    Try that should get you to the log in screen for your router. Log in using the username/password that you set for your router of if none have been set a quick google of the model should bear the default username and password. Then you'll be able to forward to ports that Tribes 2 uses.

    Unfortunately I don't know which ports Tribes 2 uses so that's up to you.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    i tried that thats what tells you to do (btw its 27999 and 28000)
  • Signal360Signal360 KeyboardCat
    You'll want to forward ports 28000 and/or 28001 (UDP).

    Make sure your LAN IP is fixed so these settings won't have to be changed in the future.

    My firewall rule just forwards 28000, so one rule should be enough.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    i forwarded 27999 and 28000 for both tcp and udp and i do have a static ip address while trying to host i turn off my firewall and windows firewall so im not sure whats wrong
  • DEATHBORNDEATHBORN Reborn from death...!
    27999 to 28003 are t2's ranges i believe.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    alright will try with those then report back

    [super edit] did not work :( tried both udp and tcp
  • TThyth AKA Electricutioner
    28000/UDP is all you need by default. The game only uses one port to host at a time. If you change your server's port, you will of course need to change the forwarding rule.

    Forwarding TCP won't do anything. Forwarding ports that aren't used to host won't do anything.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    hmm well then it should work but it doesnt :( idk any other suggestions
  • ninNninN Mapper
    First I have a question. Why do you UE when you host an undedicated server? That's what happens if you host a LAN game. You mentioned you want to play with your brother. Assuming you are both connected to the same network you can play together using LAN if the host removes T2csri.vl2 from base folder and moves it to GameData. This basically in effect removes the tribesNext patch. You can move t2csri back to play online but for some silly reason LAN games UE when it's there. Does that solve your problem?
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    not completely but that solves when i just want to play with him but sometimes i would like to open it up to a few of my friends as well but thanks for the tip :)
  • ninNninN Mapper
    I'm glad I could help in some small way because I am also having the exact same problem you are.
  • andr3wrulzandr3wrulz Shadow Assassin Lord
    lol nice well thanks and i will be sure to tell you if i find out anything
  • KrashKrash Neptune Sleeps
    If you get a UE when hosting a listen server, it usually means something in your scripts is causing it (such as the SI client patching the memory).

    The only time you will ever get that message from the master server is if the server fails to respond to an info request within the allotted time. Meaning you are either running software blocking the program from connecting, behind a router or hardware firewall without the ports mapped, or are attempting to host on a connection that could not support players from an outside network in the first place.

    If you are quite certain that the ports are forwarded, you should make sure there is nothing else stopping the connection. Set an exception for the program in whatever firewall you are running.

    If you are not certain, you could also try a UPnP mapping (see attachment) if your router model supports it and the option is enabled.

    Typing "setNetPort($Host::Port);" in the server console (without quotes) will verify the port is able to bind on the Windows end.
    startHeartbeat(); will send a new heartbeat.
  • ninNninN Mapper
    Does it matter if I have a PPPoE connection?
  • type the command connect("");
Sign In or Register to comment.